iPilot remote? - Colorado Fishing Forum

Reply
 
LinkBack Thread Tools
Old 10-02-2018, 08:50 AM   #1 (permalink)
Senior Member
 
Bionic Man's Avatar
 
Join Date: Dec 2007
Posts: 3,447
Default iPilot remote?

My iPilot remote doesn't seem to turn on. I have tried three different batteries. Does anyone have a suggestion of how to fix it short of buying a new one?
Bionic Man is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-02-2018, 08:52 AM   #2 (permalink)
Senior Member
 
Join Date: Dec 2007
Posts: 11,176
Default

Try bending the tabs up where the battery sits in the compartment.
hobiecat is offline   Reply With Quote Quick reply to this message
Old 10-02-2018, 09:14 AM   #3 (permalink)
Senior Member
 
Join Date: Aug 2010
Posts: 1,589
Default

And as simple as checking that the polarity is right.
ghostman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-05-2018, 03:10 PM   #4 (permalink)
Member
 
Micorps's Avatar
 
Join Date: Jul 2018
Location: Fountain, co
Posts: 94
Default

Not sound like the master of the obvious, but are you sure all the batteries are exactly the recommended battery or providing the required amps? Alot of batteries are close to same size is the only reason for asking. Also, what model trolling motor do you have and when was it purchased? Some have different remotes than others is the reason im asking. Minnkota has a good customer service and there are some places that will work on out of warranty units. My friend just had the electronic board go on his ultrex after some water fried it. $300 later it was fixed. Personally i would exhaust options like talking to minnkota first, i also noticed alot of very knowledgable walleye fosherman on walleye central that can offer great advice and trouble shooting, and finding someone locally that works on these trolling motors before buying a new remote. I have read posts on forums in the past of similar issue and got new remotes from minnkota under warranty and it didnt fix the problem. Luckily, ive had no issues with my terrova. But have had my unit seemingly lost communication with the remote, but unplugged my tm and fixed the problem. Lastly, do you have the foot pedal you can try to see if the tm operates as it should without using the remote. Mine came with a foot pedal also only reason i ask which may help isolate the problem. Hope you get it fogured out.
Micorps is offline   Reply With Quote Quick reply to this message
Old 10-07-2018, 08:21 PM   #5 (permalink)
Senior Member
 
Bionic Man's Avatar
 
Join Date: Dec 2007
Posts: 3,447
Default

Quote:
Originally Posted by hobiecat View Post
Try bending the tabs up where the battery sits in the compartment.
Next on my list. Traveling until Thursday.
Quote:
Originally Posted by ghostman View Post
And as simple as checking that the polarity is right.
Good thought, but that is not the problem.
Quote:
Originally Posted by Micorps View Post
Not sound like the master of the obvious, but are you sure all the batteries are exactly the recommended battery or providing the required amps? Alot of batteries are close to same size is the only reason for asking. Also, what model trolling motor do you have and when was it purchased? Some have different remotes than others is the reason im asking. Minnkota has a good customer service and there are some places that will work on out of warranty units. My friend just had the electronic board go on his ultrex after some water fried it. $300 later it was fixed. Personally i would exhaust options like talking to minnkota first, i also noticed alot of very knowledgable walleye fosherman on walleye central that can offer great advice and trouble shooting, and finding someone locally that works on these trolling motors before buying a new remote. I have read posts on forums in the past of similar issue and got new remotes from minnkota under warranty and it didnt fix the problem. Luckily, ive had no issues with my terrova. But have had my unit seemingly lost communication with the remote, but unplugged my tm and fixed the problem. Lastly, do you have the foot pedal you can try to see if the tm operates as it should without using the remote. Mine came with a foot pedal also only reason i ask which may help isolate the problem. Hope you get it fogured out.
Lots to look at here.

The remote battery is the same as what I pulled out. The ones I tried to replace were from the same lot. Maybe I wil try another lot.

I'll drag the foot pedal out of storage and try it. But I don't get anything on the remote, so I don't think that is the problem.

Trying Minnekota CS will be on the list as well.

Thanks for the advice all.
Bionic Man is offline   Reply With Quote Quick reply to this message
Old 10-07-2018, 09:20 PM   #6 (permalink)
Senior Member
 
Join Date: Feb 2005
Posts: 24,442
Default

Lots of people here with the same issue...some crazy solutions...

https://www.thehulltruth.com/boating...e-issue-2.html
__________________
Senate grants trump access to Senate floor by allowing babies under 1 year old the right to visit! Wonder if McConnell will clean his dirty nappy?
Zman is offline   Reply With Quote Quick reply to this message
Old 10-18-2018, 11:15 AM   #7 (permalink)
Senior Member
 
Join Date: Oct 2010
Location: Colorado Springs & Woodland park
Posts: 1,290
Default

I whack mine against ny palm that turns mine on. It acts up now and then
tl1000r is offline   Reply With Quote Quick reply to this message
Old 10-18-2018, 01:27 PM   #8 (permalink)
Senior Member
 
Join Date: Mar 2006
Posts: 2,434
Default

Quote:
Originally Posted by tl1000r View Post
I whack mine against ny palm that turns mine on. It acts up now and then
Inappropriate. This is a family friendly forum.
__________________
waterfowler is offline   Reply With Quote Quick reply to this message
Old 10-18-2018, 04:11 PM   #9 (permalink)
Senior Member
 
tangler's Avatar
 
Join Date: Jul 2007
Posts: 4,032
Default

Def try different lot of batteries. Check their expiration.
tangler is offline   Reply With Quote Quick reply to this message
Old 10-18-2018, 11:55 PM   #10 (permalink)
Senior Member
 
Bionic Man's Avatar
 
Join Date: Dec 2007
Posts: 3,447
Default

Thanks for the suggestions. Once I get back from chasing birds I will dive in a little deeper.


Sent from my iPhone using Tapatalk
Bionic Man is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Colorado Fishing Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Minn Kota i-Pilot Terrova Trolling Motor 80 US2 60" with iPilot & Pedal TthePikester Buy and Sell 21 06-02-2017 10:09 AM
Terrova iPilot with link? rattman Colorado Fishing Lounge 4 03-25-2014 07:09 AM
Minn Kota v2 55 12v with ipilot Jdaddy Buy and Sell 11 04-14-2013 07:07 PM
Minnkota Terrova with Ipilot versus Minnkota V2 with Ipilot??? Zman Colorado Fishing Lounge 46 03-07-2012 11:59 AM
Killer deal on iPilot for Minn Kota Terrova Oyey Buy and Sell 4 12-29-2011 04:12 PM

» Forum Search
» Insurance
Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 09:48 AM.


Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0 PL3
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.