Colorado Fisherman Forum banner
1 - 20 of 39 Posts

·
Registered
Joined
·
2,151 Posts
Discussion Starter · #1 ·
took out my fl-18 today and shortly after turning it on it started spinning uncontrollably.rendering it useless for fishing. we tried my friends battery and it seemed to work fine. so thinking i forgot to charge the battery and everything would be fine. well when i got home and plugged the battery in it shows 100% and works fine.anybody know whats going on with this.?the unit also seems to work ok
 

·
Registered
Joined
·
428 Posts
If it worked ok with friends battery...sounds like you need a battery.How old,etc? Have a voltmeter? Battery should be 12.6 minimum after charging,followed by quick usage to remove surface charge.

One of my vexilars went tits up last time I was metro icing. Found lots of useful troubleshooting info on vex page. Mine wouldn't read bottom well or pick up jig. Got it home,performed transducer test. All good,hmm.

Used it today, no issues with either transducer I used(robbed other unit).Battery is new this year. Bummer when broke stuff works...hope you get it fixed. Ill follow up on mine too.

Oh, hi Glenn
 

·
Registered
Joined
·
2,151 Posts
Discussion Starter · #3 ·
thanks dude I'm pretty sure its the battery, I'm charging it right now and will test it with a voltmeter when done. forgot what its like to fish without a finder. don't know how anyone does it.
 

·
Registered
Joined
·
44 Posts
I have one of those 7amp. Batt. From cabelas. They told me max 8 hrs. On charger. Left it on by accident one night for 12 hrs. Did exactly what yours is doing. 18 bucks without charger, back in business
 

·
Registered
Joined
·
2,151 Posts
Discussion Starter · #7 ·
i think i must have forgotten to put it on the charger, i checked it a little while ago and it showed 13.44 I'm going to let it sit for awhile and check to see if it holds. won't make that mistake again.
 

·
Registered
Joined
·
2,771 Posts
If you put it in the car the night before and it's cold enough you can freeze the battery and it won't work.

I used to carry a spare battery for long days, now I use a lithium (electric bike) battery because it's lighter and lasts longer.
 

·
Registered
Joined
·
803 Posts
If you put it in the car the night before and it's cold enough you can freeze the battery and it won't work.

I used to carry a spare battery for long days, now I use a lithium (electric bike) battery because it's lighter and lasts longer.
Where did you get that lithium battery at? I still have the 2 extra batteries that I got from you.
 

·
Registered
Joined
·
633 Posts
Glenn, my vex did the same thing this weekend because I forgot to charge the battery too. My "Low Battery" light came on and about 20 minutes later it started spinning like yours did. Charged the battery and it's good to go. Did yours work this weekend?
Albow I'd like to know where you got your lithium battery too. Lighter and lasts longer sounds GOOD. Also $.
 

·
Registered
Joined
·
749 Posts
A lot of times a battery read 12 volts but once you turn the unit on it may drop to 9 volts. The battery reached a top charge from being charged too many times. Some times you can place a 12 volt bulb across it until it reaches zero volts. Then charge it again most times it needs to be replaced.
 

·
Registered
Joined
·
2,151 Posts
Discussion Starter · #13 ·
after charging the battery, when it initially came off the charger it read almost 13 volts. now after five days off the charger it is holding steady at 11.75 volts,do i still need a new battery or is this about normal?
 

·
P I K E
Joined
·
10,264 Posts
Glenn, my FL-18 started doing the same thing last year and would be OK on a full charge but wouldn't last long. It's about 8 years old, got my money out of it so a new battery is in order.
 

·
Registered
Joined
·
4,805 Posts
Puh-leeze! Everybody knows Marcums kick Vex ass. Just ask Tommy-
Whatever theres a reason I sold you my Marcum, Marcums hands down second place. I have owned both and was able to give a fair unbiased opinion of the two. Slayer maybe I would be a little more impressed if you ever used the zoom feature but the only thing Ive seen from yours is standard view showing many false marks. Guess there hard to put in zoom mode Tony has the same problem
 
1 - 20 of 39 Posts
Top